В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
alyssasweetgirl
alyssasweetgirl
13.01.2020 17:30 •  Информатика

Написать программу, которая позволяет ввести имя bmp-файла, считать его заголовки и вывести на консоль информацию о размере файла, ширине и
высоте в пикселях, количестве бит на пиксель, разрешении горизонтальном
и вертикальном (количестве пикселей на метр), типе сжатия (без сжатия / 4бит
RLE / 8бит RLE). Подготовьте несколько файлов изображений и проверьте на
них Вашу программу.

Показать ответ
Ответ:
TheATN
TheATN
09.02.2020 15:46

Объяснение:

Какие служебные слова применяются для записи цикла с постусловием

Выберите несколько из 4 вариантов ответа:

1) End 3) Repeat

2) Until 4) Begin

Задание 2

Вопрос:

Как найти элемент массива с определенным значением?

Выберите один из 3 вариантов ответа:

1) Отсортировать массив и выбрать максимальный индекс.

2) Перебирать элементы массива пока они не закончатся или пока не будет найден искомый.

3) Выбрать один элемент массива, предположить его искомым и сравнить с оставшимися, меняя в процессе предполагаемый искомый элемент.

Задание 3

Вопрос:

Установите верный порядок следования команд при поиске в массиве из 50 элементов, элемента равного k

Укажите порядок следования всех 4 вариантов ответа:

_1_ if a[i]=k then writeln (i); _2_ while (a[i]<>k) and (i<50) do

_1_ i:=1; __ i:=i+1;

Задание 4

Вопрос:

Какая команда пропущена в данном участке программы, отвечающем за поиск максимального элемента массива. Запишите команду без пробелов.

r:=1;

for i:=2 to n do

if a[i]>a[r]

then ...

Запишите ответ:

Задание 5

Вопрос:

Запишите без пробелов команду, которая пропущена в данном алгоритме сортировки массива по убыванию методом пузырька.

p:=false;

while p=false do

begin

...

for i:=1 to n-1 do

if a[i] then begin

p:=a[i];

a[i]:=a[i+1];

a[i+1]:=p;

end;

end;

Запишите ответ:

Задание 6

Вопрос:

Какое служебное слово пропущено в данной записи цикла с постусловием?

repeat

i:=i-1;

... i=0;

Запишите ответ:until

Задание 7

Вопрос:

Как называется описанный метод сортировки по возрастанию?

Проходя по массиву, ищем два соседних элемента, которые расположены не по возрастанию. Найдя такие элементы, меняем их местами. Продолжаем до тех пор, пока за весь проход по массиву не будет сделано ни одной перестановки.

Выберите один из 4 вариантов ответа:

1) Метод перебора

2) Метод пузырька

3) Метод выбора

4) Метод последовательных перестановок

Задание 8

Вопрос:

Что такое сортировка?

Выберите один из 3 вариантов ответа:

1) Изменение индексов элементов массива

2) Изменение порядка следования элементов в массиве в соответствии с определенным признаком

3) Изменение значений элементов массива

Задание 9

Вопрос:

Какие существуют типы задач на поиск элементов в массиве?

Выберите несколько из 4 вариантов ответа:

1) Удаление элемента массива

2) Найти элемент с указанным значением

3) Добавление элемента

4) Найти максимальный или минимальный элемент

Задание 10

Вопрос:

Установите верный порядок следования команд при сортировке массива из 10 элементов по возрастанию методом выбора.

Укажите порядок следования всех 7 вариантов ответа:

__ a[i]:=a[j];

__ for i:=j+1 to 10 do

__ a[j]:=p;

__ p:=a[i];

__ if a[j] __ for j:=1 to 9 do

__ end;

0,0(0 оценок)
Ответ:
Tililinka
Tililinka
20.08.2021 01:32

function F(x: real): real;

begin

 F := 3 * sin(x) + 2 * sqr(x) - 1;

end;

var

 a, b, h, x, Fa, Fx: real;

begin

 Write('Введите через пробел начало интервала, конец и шаг: ');

 Readln(a, b, h);

 x := a; Fa := F(a);

 repeat

   Fx := F(x);

   if Fx = 0 then Writeln('Найден корень ', x:0:3)

   else

   if Fx * Fa < 0 then

     Writeln('Найден интервал изоляции корня (', a:0:3, ';', x:0:3, ')');

   a := x; Fa := Fx; x := x + h

 until x > b;

end.

Тестовое решение:

Введите через пробел начало интервала, конец и шаг: 0 1.95 0.15

Найден интервал изоляции корня (0.150;0.300)

Введите через пробел начало интервала, конец и шаг: -5 5 0.1

Найден интервал изоляции корня (-1.500;-1.400)

Найден интервал изоляции корня (0.200;0.300)

Объяснение:

Лови! Удачки!
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота