В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
nastiadair
nastiadair
18.02.2022 17:27 •  Информатика

Написать программу, которая просит ввести 10 целых чисел и считает сколько из них положительный, отрицательно и нулей

Показать ответ
Ответ:
Наденька2000
Наденька2000
03.10.2020 11:47
Var a,n1,n2,n3,i:integer;
begin
  for i:=1 to 10 do begin
    write('Введите ',i, ' число ');
    readln(a);
    if a = 0 then n1:=n1+1 else
      if a<0 then n2:=n2+1 else n3:=n3+1;
   end;
   writeln('Равных 0 : ',n1);
   writeln('Меньше 0 : ',n2);
   writeln('Больше 0 : ',n3);
 end.
  
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота