В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Yanaaa13
Yanaaa13
03.05.2023 16:16 •  Информатика

Написать программу, которая решает следующую задачу.
Проверить, кратно ли число х пяти.
Выдержка из математики: число кратно пяти,
если оно делится на 5 без остатка. То есть
остаток от деления этого числа на 5 должен быть
равен нулю.​ Помигите

Показать ответ
Ответ:
Dan4ikFun4ik
Dan4ikFun4ik
25.04.2021 03:53

Program fantscrin;

 const n = 15;

 const m = 10;

 Var x: array [1..n] of real;

     y: array [1..n] of real;

     z: array [1..n+m] of real;

     i,e_1,e_2,g:integer; s,p,min:real;

     

Begin

 for i:=1 to n do

   x[i]:=random(20)-10;

 for i:=1 to m do

   y[i]:=random(10)-5;

   

 for i:=1 to n do

   write(x[i],'  ');

   

 s:=0;  

 for i:=1 to n do

   if(i mod 2 <> 0) then s:=s+x[i];

   

 for i:=1 to n do

   if (x[i] < 0) then

                 begin

                   e_1:=i;

                   break;

                 end;

 for i:=n downto 1 do

   if (x[i] < 0) then

                 begin

                   e_2:=i;

                   break;

                 end;

 

 p:=1;

 for i:=e_1 to e_2 do

   p:=p*x[i];

 

 

 for i:=1 to n do

   z[i]:=x[i];

 for i:=1 to m do

   z[n+i]:=y[i];

 

 min:=z[1];

 g:=1;

 for i:=2 to n+m do

   if (z[i] < min) then  

                   begin

                     min:=z[i];

                     g:=i;

                   end;

 writeln('');

 writeln('1. : ',s);

 writeln('2. : ',p);

 for i:=1 to m do

   write(y[i],'  ');

 writeln('');

 for i:=1 to n+m do

   write(z[i],'  ');

   

 for i:=g to n+m-1 do

   z[i]:=z[i+1];

 

 z[n+m]:=0;

 

 writeln('');

 writeln(g);

 for i:=1 to n+m-1 do

   write(z[i],'  ');

End.

0,0(0 оценок)
Ответ:
ladyhyuna
ladyhyuna
09.05.2021 14:36

Сам Код:

class Girafe:

   def dance(self):

       happy_girafe.l_f_1()

       happy_girafe.l_f_2()

       happy_girafe.l_f_3()

       happy_girafe.l_f_4()

       happy_girafe.l_f_2()

       happy_girafe.l_f_4()

       happy_girafe.l_f_3()

       happy_girafe.l_f_1()

   pass

   def l_f_1(self):

       print ('левая нога впереди')

   pass

   def l_f_2(self):

       print ('левая нога сзади')

   pass

   def l_f_3(self):

       print ('правая нога впереди')

   pass

   def l_f_4(self):

       print ('правая нога сзади')

   pass

pass

happy_girafe = Girafe()

print ("Посмотрите! Посмотрите! Жираф умеет танцевать! Введите happy_girafe.dance() Чтобы увидеть его танец!")

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота