В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
stovolosova03
stovolosova03
17.02.2021 00:17 •  Информатика

Написать программу которая решает уравнение ax^2+bx+c=0 . если d< 0 то решений нет , если d=0 то 1 корень. еси d > 0 - 2 корня

Показать ответ
Ответ:
84737263748
84737263748
07.10.2020 20:51
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
var (a,b,c):=ReadReal3('введите a, b и c через пробел');
var D:=b*b-4*a*c;
if D>0 then write('два различных корня: x1=',(-b+sqrt(D))/(2*a),'; x2=',(-b-sqrt(D))/(2*a)) else if D=0 then
write('два совпадающих корня: x1=x2=',-b/(2*a)) else
write('нет действительных корней');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота