В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
lolSashalolo
lolSashalolo
26.10.2020 13:12 •  Информатика

Написать программу ,которая с клавиатуры запрашивает размер двумерного массива найти и вывести на экран сумму значений элементов расположенных в левом верхнем углу матрицы и правом

Показать ответ
Ответ:
Grebeshe
Grebeshe
08.10.2020 12:38
Осталось понять что подразумевалось под словом угол.
Ну допустим что угол это одна самая угловая ячейка

var
a: array [1..20,1..20] of Integer ;
i,j,n,sum:Integer;
begin
Writeln('Введмте размер двумерного массива (2<=n<=20)');
ReadLn(n);
for i:=1 to n do
begin
for j:=1 to n do
begin
a[i,j]:=Random(20);
Write(a[i,j]:3);
end;
WriteLn();
end;
sum:=a[1,1]+a[n,n];
WriteLn('Сумма значений элементов расположенных в левом верхнем и в правом нижнем углах = ', sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота