В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
WWW2014
WWW2014
06.07.2020 10:13 •  Информатика

Написать программу, которая считает количество чисел «Пифагоровой тройки» и количество итераций. «Пифагорова тройка» - целые числа, которые удовлетворяют равенству: а^2 + в^2 = с^2. Python

Показать ответ
Ответ:
Sanek27rus
Sanek27rus
24.03.2023 14:40

Как создать свой Layout с элементами (LinearLayout,Spinner,View и т.п.) внутри так, чтобы управлять их расположением и анимацией?

main_activity.xml:

   <LinearLayout

       android:id = "@+id/window_1"

       android:layout_width="200dp"

       android:layout_height="100dp"

       android:orientation="vertical">

       <Spinner

           android:id="@+id/WindowSpinner_1"

           android:layout_width="match_parent"

           android:layout_height="?attr/actionBarSize"/>

       <FrameLayout

           android:id="@+id/container_1"

           android:layout_width="match_parent"

           android:layout_height="match_parent">

       </FrameLayout>

   </LinearLayout>

   <LinearLayout

       android:id = "@+id/window_2"

       android:layout_width="200dp"

       android:layout_height="100dp"

       android:orientation="vertical">

       <Spinner

           android:id="@+id/WindowSpinner_2"

           android:layout_width="match_parent"

           android:layout_height="?attr/actionBarSize"/>

       <FrameLayout

           android:id="@+id/container_2"

           android:layout_width="match_parent"

           android:layout_height="match_parent">

       </FrameLayout>

   </LinearLayout>

   <LinearLayout

       android:id = "@+id/window_3"

       android:layout_width="200dp"

       android:layout_height="100dp"

       android:orientation="vertical">

       <Spinner

           android:id="@+id/WindowSpinner_3"

           android:layout_width="match_parent"

           android:layout_height="?attr/actionBarSize"/>

       <FrameLayout

           android:id="@+id/container_3"

           android:layout_width="match_parent"

           android:layout_height="match_parent">

       </FrameLayout>

   </LinearLayout>

   <LinearLayout

       android:id = "@+id/window_4"

       android:layout_width="200dp"

       android:layout_height="100dp"

       android:orientation="vertical">

       <Spinner

           android:id="@+id/WindowSpinner_4"

           android:layout_width="match_parent"

           android:layout_height="?attr/actionBarSize"/>

       <FrameLayout

           android:id="@+id/container_4"

           android:layout_width="match_parent"

           android:layout_height="match_parent">

       </FrameLayout>

   </LinearLayout>

</com.android.prog.CustomLayout>

класс CustomLayout.java:

public class CustomLayout extends LinearLayout {

public CustomLayout(Context context) {

   super(context);

}

public CustomLayout(Context context, AttributeSet attrs, int defStyleAttr, int defStyleRes) {

   super(context, attrs, defStyleAttr, defStyleRes);

}

public CustomLayout(Context context, AttributeSet attrs, int defStyleAttr) {

   super(context, attrs, defStyleAttr);

}

public CustomLayout(Context context, AttributeSet attrs) {

   super(context, attrs);

}

public void doSomefing{//Задаём действия с элементами внутри CustomLayout

}

}

Объяснение:

0,0(0 оценок)
Ответ:
Oksanaa11
Oksanaa11
24.03.2023 14:40

Если создать шаблон строки с автозаполнением, то можно немного у код:

import sys

num_steps = int(sys.argv[1])

fmt_template = '{}.{:>%d}' % num_steps

for x in range(1, num_steps + 1):

   print(fmt_template.format(x, '#' * x))

При num_steps = 4:

1.   #

2.  ##

3. ###

4.

Объяснение:

Все аргументы функции print, указанные через запятую, выводятся разделенные пробелом, отсюда и нестыковка.

Можно так попробовать:

for x in range(1, c+1):

   print('{0}{1}{2}'.format(x, " " * (c - x), '#' * x))

Для c = 3:

1  #

2 ##

3###

Либо заменить запятую конкатенацией (знак +):

print(str(x) + " " * (c - x) + '#' * x)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота