В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
VarmaleyYouTuber
VarmaleyYouTuber
03.05.2023 16:40 •  Информатика

Написать программу , которая считает, сколько раз последовательности из 10 чисел встречается введённое с клавиатуры число а.

Показать ответ
Ответ:
Chechenec001
Chechenec001
17.09.2020 23:15
Var i,k,n: integer;
    a: array[1..10] of integer;
begin
  k:=0;    randomize;
  writeln('число:  '); readln(n);
  writeln('последовательность из 10 элементов');
  for i:=1 to 10 do
  begin
    a[i]:=random(50);
    write(a[i],' ');
    if a[i]=n then k:=k+1;
  end;
  writeln;
  if k>0 then
      writeln('число ',n,' встречается ',k,' раз')
  else
      writeln('числа ',n,' нет в последовательности');
  readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота