В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
whcxjsg
whcxjsg
03.05.2022 10:54 •  Информатика

Написать программу, которая считает значение y при любом целом значении x (паскаль) y = 1/(x+1)^2

Показать ответ
Ответ:
CagBak
CagBak
10.10.2020 12:55

begin

 Println(1/Sqr(ReadInteger+1))

end.

Примеры:

7

0.015625

-4

0.111111111111111

0

1

-1

Infinity (это означает бесконечность)

0,0(0 оценок)
Ответ:
миру3
миру3
10.10.2020 12:55

program smth;

var x, y : real;

Begin

writeln ('Введите значение x');

readln (x);

y := 1 / sqr(x+1);

if (sqr(x+1) = 0) then

writeln ('Знаменатель = 0')

else

writeln ('Значение y = ', y);

end.

----------------------------------

Или

----------------------------------

program smth;

var x, y : real;

Begin

writeln ('Введите значение x');

readln (x);

if (x <> -1) then

Begin

y := 1 / sqr(x+1);

writeln ('Значение y = ', y)

end

else

writeln ('Знаменатель = 0');

end.


Написать программу, которая считает значение y при любом целом значении x (паскаль) y = 1/(x+1)^2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота