В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Maximus20161
Maximus20161
14.04.2020 16:34 •  Информатика

Написать программу, которая считывает текст из файла и выводит на экран предложения, содержащие цифры.

Показать ответ
Ответ:
Glowly
Glowly
28.05.2020 20:32

Программа:

program files;

var f: text;

   c: string;

begin

 

 assign(f, 'path/to/file.txt');

 reset(f);

 

 while not eof(f)

 do begin

      readln(f,c);

      if(c.Contains('1') or c.Contains('2')

           or c.Contains('3') or c.Contains('4')

             or c.Contains('5') or c.Contains('6')

               or c.Contains('7') or c.Contains('8')

                 or c.Contains('9'))

      then writeln(c);

 end;

 

 close(f);

 

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота