В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Kabesov
Kabesov
30.09.2020 04:55 •  Информатика

Написать программу, которая сортирует массив по убыванию и ищет в нем элемент, равный x (это число вводится с клавиатуры). использовать двоичный поиск.

Показать ответ
Ответ:
rakitina03
rakitina03
28.06.2020 12:19
uses crt;
var a, b, c, n, i, j :integer;   
s :array [1..10000] of integer;
begin
   clrscr;
   writeln ('Vvedite razmer masiva');
   read (n);
   writeln  ('Vvedite chislo X');
   read (a);
   for i:=1 to n do 
   begin 
      writeln ('Vvedit s[', i, '] element'); 
      read (s[i]); 
   end;
   for i:=1 to n do 
      for j:=1 to n-1 do 
         if s[j]<s[j+1] then   
         begin   
            b:=s[j];   
            s[j]:=s[j+1];   
            s[j+1]:=b;   
         end;
   for i:=1 to n do 
   begin 
      write (s[i], ' '); 
      if s[i]=a then inc (c); 
   end;
writeln;
if c>0 then writeln ('3adanoe chislo prisytstvyet') else writeln('3adanoe chislo otsytstvyet');
end.

P.S. Надеюсь на благодарность и лучший ответ.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота