В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ZHENYAKIM2008
ZHENYAKIM2008
10.02.2023 05:43 •  Информатика

Написать программу которая сравнивает сумму четных значений с нечетными значением !

Показать ответ
Ответ:
npodolskaa191
npodolskaa191
08.10.2020 12:14
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (so,se):=(0,0);
  ReadSeqIntegerWhile(t->t>0).ForEach(t->if t.IsOdd then so+=t else se+=t);
  Write('Сумма четных ',se,' ');
  if se>so then Write('>')
  else
    if se=so then Write('=')
    else Write('<');
  Writeln(' суммы нечетных ',so)
end.

Пример
3245 6774 23241 5645 967 32234 123 65 2134 0
Сумма четных 41142 > суммы нечетных 33286

Программа считывает данные, пока они являются натуральными числами.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота