В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
elenchik2006
elenchik2006
23.08.2022 21:16 •  Информатика

Написать программу, которая в матрице a(n,m) находят все элементы , равные числу, введённому с клавиатуры. подсчитать числа таких элементов. в dev c++.

Показать ответ
Ответ:
NasVest
NasVest
09.10.2020 10:37

#include "stdafx.h"

#include <iostream>

#include <ctime>

using namespace std;

 

int main()

{

srand(time(0));

int n, m, k;

 

cout << "N = ";

cin >> n;

cout << "M = ";

cin >> m;

cout << "K = ";

cin >> k;

 

int A[100][100];

for (int i = 0; i < n; i++)

{

 for (int j = 0; j < m; j++)

 {

  A[i][j] = 1 + rand() % 10; // от 1 до 10

 }

}

cout << endl;

for (int i = 0; i < n; i++)

{

 for (int j = 0; j < m; j++)

 {

  cout << A[i][j] << " ";

 }

 cout << endl;

}

int temp = 0;

for (int i = 0; i < n; i++)

{

 for (int j = 0; j < m; j++)

 {

  if (A[i][j] == k)

   temp++;

 }

}

cout << temp << endl;

system("pause");

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота