В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Написать программу, которая водит натуральные числа от a до b и выводит все простые числа в диапазоне от a до b. на python !

Показать ответ
Ответ:
allaxarchenko
allaxarchenko
11.05.2023 00:19
";  // Вывод сообщения в консоль

   return 1;  // Конец программы с кодом ошибки

 }

 else // Иначе

 {  

   fuel -= fuel_cons * distance_a_b;  // Емкость бака = емкость бака - расход топлива на 1 км * расстояние из пункта А в пункт В (узнаем количеств оставшегося топлива)

 }

 int distance_b_c, weight_b;   // Создание целочисленных переменных:

distance_b_c - расстояние из пункта В в пункт Сweight_b - вес груза в пункте В

 cout << "Погрузка/Разгрузка в точке B: ";  // Вывод сообщения в консоль

 cin >> weight_b;  // Ввод с клавиатуры веса груза в пункте В

 weight_a += weight_b;  // Выясняем, на сколько был дозагружен/разгружен самолет в пункте В (Вес в пункте А + Вес в пункте В)

 fuel_cons = fuel_consumption(weight_a);  // Переменной fuel_cons присваиваем возвращаемое значение из функции fuel_consumption (расход топлива на 1 км)

 cout << "Расстояние от пункта B в пункт C (км): ";  // Вывод сообщения в консоль

 cin >> distance_b_c;  // Ввод с клавиатуры расстояния из пункта В в пункт С

 fuel = (distance_b_c * fuel_cons - fuel);  // Выясняем, на сколько необходимо дозаправить самолет, чтобы долететь до пункта С (Емкость бака = расстояние из пункта В в пункт С * расход на 1 км - емкость бака)

 cout << "В пункте B самолет необходимо дозаправить на минимум (л): ";  // Вывод сообщения в консоль

 cout << fuel;  // Вывод значения переменной fuel

}

0,0(0 оценок)
Ответ:
gfgfvfvfuelrjds
gfgfvfvfuelrjds
27.09.2022 13:43

k = int(0)

m = int(input("Введите M: "))

while m > 0:

 if m % 10 % 2 == 0:

   k += 1

 m //= 10

print("Четных цифр = ", k)

Объяснение:

k = int(0)  // Создание целочисленной переменной k и присвоение ей значения 0 (ноль)

m = int(input("Введите M: "))  // Ввод с клавиатуры целочисленной переменной m

while m > 0:  // Пока значение переменной m > 0

 if m % 10 % 2 == 0:  // Если остаток от деления значения переменной m на 10 и на 2 = 0

   k += 1  // К значению переменной k прибавляем 1 (единицу)

 m //= 10  // Отделяем последнее число от значения переменной m путем целочисленного деления на 10

print("Четных цифр = ", k) // Вывод значения переменной k

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота