Написать программу, которая вводит 5 чисел (а, в, с, к, л). Выполняет поиск максимального и минимального элемента используя функцию поиска максимального и минимального из трех и находит факториал 5 чисел введенных пользователем с клавиатуры.
/*Дан массив X(N,M) .Найти среднее арифметическое тех строк массива, первый элемент которых положительный*/#include <iostream>#include <time.h>#define M 5#define N 5using namespace std; void printArray(int *mas, int n,int m)//инициализация и вывод массива { srand(time(0)); for (int i = 0; i < n; i++) { for (int j = 0; j < m; j++) { *mas = rand() % 21-10; cout << *mas << "\t"; mas++; } cout << endl; }}
void srArray(int mas[][M], int n)//нахождение и подсчет тех строк, где первый элемент положительный{ int a; double sum = 0; for (int i = 0; i < n; i++) { double sr = 1; if (mas[i][0] > 0) { for (int j = 0; j < M; j++) { sum += mas[i][j]; } sr = sum / M; cout << "Ср элеменитов " << i + 1 << "-й строки = " << sr << endl; } else ; } }
void main()//основная функция{ setlocale(LC_ALL, "rus"); int x[N][M]; printArray(&x[0][0], N, M); cout << endl; cout << ""<<endl; srArray(x, N); system("pause");}
1) Ақпаратты бағдарламаға түрлендіру тапсырмасын орындайтын және барлық есептеу процестерін басқаруды жүзеге асыратын компьютердің орталық бөлігі.
2) Мақсатына сәйкес процессор регистрлері ерекшеленеді: аккумулятор - арифметикалық және логикалық операциялардың аралық нәтижелерін және енгізу-шығару нұсқауларын сақтау үшін қолданылады; ... контроллерлер - процессордың күйін басқаратын ақпараттарды, сонымен қатар жүйелік кестелердің адрестерін сақтайды.
void printArray(int *mas, int n,int m)//инициализация и вывод массива { srand(time(0)); for (int i = 0; i < n; i++) { for (int j = 0; j < m; j++) { *mas = rand() % 21-10; cout << *mas << "\t"; mas++; } cout << endl; }}
void srArray(int mas[][M], int n)//нахождение и подсчет тех строк, где первый элемент положительный{ int a; double sum = 0; for (int i = 0; i < n; i++) { double sr = 1; if (mas[i][0] > 0) { for (int j = 0; j < M; j++) { sum += mas[i][j]; } sr = sum / M; cout << "Ср элеменитов " << i + 1 << "-й строки = " << sr << endl; } else ; }
}
void main()//основная функция{ setlocale(LC_ALL, "rus"); int x[N][M]; printArray(&x[0][0], N, M); cout << endl; cout << ""<<endl; srArray(x, N); system("pause");}
1) Ақпаратты бағдарламаға түрлендіру тапсырмасын орындайтын және барлық есептеу процестерін басқаруды жүзеге асыратын компьютердің орталық бөлігі.
2) Мақсатына сәйкес процессор регистрлері ерекшеленеді: аккумулятор - арифметикалық және логикалық операциялардың аралық нәтижелерін және енгізу-шығару нұсқауларын сақтау үшін қолданылады; ... контроллерлер - процессордың күйін басқаратын ақпараттарды, сонымен қатар жүйелік кестелердің адрестерін сақтайды.
3) Процессордың негізгі сипаттамалары:
• тактілік жиілік;
• разрядтылық;
• жұмыс кернеуі;
• кэш-жады өлшемі.