В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
esimahin
esimahin
13.08.2021 22:56 •  Информатика

Написать программу, которая вводит массив из n целых чисел и выводит на экран этот же массив в прямом и обратном порядке. протестировать программу на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

Показать ответ
Ответ:
andreeva1979ir
andreeva1979ir
12.06.2020 02:15

var
m: array [1..10000] of integer;
i,n: integer;

begin
readln(n);
for i := 1 to n do
read(m[i]);
for i := 1 to n do
write(m[i], ' ');
writeln;
for i := n downto 1 do
write(m[i],' ')
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота