В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Тотошка33
Тотошка33
09.04.2022 01:09 •  Информатика

Написать программу, которая вводит с клавиатуры данные, содержащие информацию: фамилия студента, год рождения, оценки по 5-ти экзаменам и создает массив структур. Подсчитать средний возраст студентов группы. Написать программу на C++, желательно с комментариями.

Показать ответ
Ответ:
Dog7771
Dog7771
16.01.2022 12:00

#include <iostream>

#include <string>

#define SIZE 3

/*

Структура содержит 3 поля, фамилия и оценки имеют тип string, поле с годом рождения имеет тип int;

Также имеется метод, с которого происходит ввод информации.

*/

struct student {

std::string surname;

int birthYear;

std::string marks;

void InputInfo() {

 std::cout << "Фамилия студента: ";

 getline(std::cin, surname);

 std::cout << "\nГод рождения студента: ";

 std::cin >> birthYear;

 std::cin.ignore();

 std::cout << "\nОценки студента: (через пробел): ";

 getline(std::cin, marks);

}

};

/*

В основной функции мы создаем массив структур "group" размера SIZE (SIZE объявили выше)

Затем находим сумму возрастов и делим ее на размер массива структур

*/

signed main() {

setlocale(LC_ALL, "Rus");

student group[SIZE];

int _sumAge = 0;

for (int i = 0; i < SIZE; ++i) {

 group[i].InputInfo();

 _sumAge += 2022 - group[i].birthYear;

}

std::cout << "\nСредний возраст студентов в группе:" << _sumAge / SIZE;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота