В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
nastorekhova20
nastorekhova20
04.09.2021 03:55 •  Информатика

Написать программу, которая вводит с клавиатуры натуральные числа не превышающие 30000 до тех пор, пока не будет введено число 0. в конце работы на экран выводятся: количество введенных чисел, их сумма, произведение, среднее значение, максимальное и минимальное числа.

Показать ответ
Ответ:
SelfishDog
SelfishDog
04.08.2020 10:12
Program n1;
var a,sum,k,max,min: integer;
p: real;
begin
readln(a);
max:=a;
min:=a;
p:=1;
k:=0;
sum:=0;
while a<>0 do
begin
k:=k+1;
sum:=sum+a;
p:=p*a;
if a>max then max:=a;
if a<min then min:=a;
readln(a);
end;
writeln('сумма: ',sum,'; кол-во: ',k,'; max=',max,'; min=',min,'; произв: ',p,'; срзнач: ',sum/k); 
end.
0,0(0 оценок)
Ответ:
annaa021
annaa021
04.08.2020 10:12
Код на С++

// Example program#include <bits/stdc++.h>
using namespace std;
int main(){  int mas[100], i, maxl = -1, minl = 30000, sum = 0, k = 0, pro = 1;int n = 1;
while (n != 0) { cin >> n;   if (n != 0) {     k++; maxl = max(n, maxl); minl = min(n, minl); pro = pro * n; }  sum = sum + n;}
cout << k << endl;cout << sum << endl;cout << pro << endl;cout << sum / k << endl;cout << maxl << endl;cout << minl << endl;  return 0;  }
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота