В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
khavakim
khavakim
12.11.2022 15:29 •  Информатика

Написать программу, которая вводит с клавиатуры не пустой массив целых чисел, печатает его, затем находит максимальный и минимальный элемент массива, выводит их на экран.

Показать ответ
Ответ:
mmmmmaaaaruuu69
mmmmmaaaaruuu69
10.06.2020 22:32

var  a: array [1..100] of integer;
i,n,min,max:integer;
Begin
    read(n);
    for i := 1 to n do
        read(a[i]);

    min:=a[1];
    max:=a[1];
    for i:= 1 to n do begin
        write(a[i],' ');
        if max<a[i] then max:=a[i];
        if min>a[i] then min:=a[i];
    end;
    writeln(min,max);
End.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота