В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
katgri83
katgri83
01.09.2021 07:20 •  Информатика

Написать программу которая вводит с клавиатуры одномерный массив из 10 целых чисел после чего выводит количество ненулевых элементов. перед вводом каждого элемента должна выводиться подсказка с номером элемента !

Показать ответ
Ответ:
polinka3089
polinka3089
06.10.2020 05:15
Const n=10;
var a: array[1..n] of integer;
k,i: integer;
begin
k:=0;
for i:=1 to n do
begin
writeln('элемент', i);
readln(a[i]);
if a[i] <> 0 then k:=k+1
end;
writeln(k)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота