В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Брат111111111
Брат111111111
14.09.2022 02:48 •  Информатика

Написать программу, которая вводит с клавиатуры одномерный массив из пяти целых чисел и выводит количество ненулевых элементов

Показать ответ
Ответ:
Cektumcempra
Cektumcempra
14.08.2020 08:49
Program prog;
Uses crt;

var a: array [1..5] of integer;
    i,k: integer;

begin
clrscr;

for i:=1 to 5 do
    begin
    write('a[',i,'] = ');
    readln(a[i]);
    if (a[i]<>0) then
    inc(k);
    end;

    writeln;
    write('k = ', k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота