В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Angela1156
Angela1156
13.09.2020 01:09 •  Информатика

Написать программу , которая вычислит отдельные суммы четных и нечетных чисел натурального ряда и их произведения

Показать ответ
Ответ:
kudadiana3101
kudadiana3101
27.07.2020 22:32
Const
N = 7;
Var
A:array[1..N]of integer;
i:integer;
S,Sn,P,Pn:real;
Begin
S:=0;
Sn:=0;
P:=1;
Pn:=1;
For i:= 1 to N do
Begin
A[i]:=random(7)+1;
Write(A[i],' ');
if A[i] mod 2 = 0 then
Begin
S:=S+A[i];
P:=P*A[i];
End
else
Begin
Sn:=Sn+A[i];
Pn:=Pn*A[i];
End
End;
WriteLn;
WriteLn('Сумма чётных элементов =',S);
WriteLn('Произведение чётных элементов =',P);
WriteLn('Сумма НЕчётных элементов =',Sn);
WriteLn('Произведение НЕчётных элементов =',Pn);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота