В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Krasoto4kayoy
Krasoto4kayoy
16.04.2023 11:58 •  Информатика

Написать программу, которая вычисляет число x6 с трех операций умножения

Подсказка:

Вычислить рациональным т.е. за минимальное количество операций: y = x6 (y = (x3 ) 2 = (x2 * x) 2 , то есть за 3 операции

Показать ответ
Ответ:
kmurtazalieva72
kmurtazalieva72
12.08.2020 12:38

#include <iostream>

using namespace std;

int main()

{

   

   ///x = x^6 - надо вычеслить за (3) - опирации умножения.

   cout << "x= ";

   int x;

   cin >> x;

   cout << endl;

   

   x = (x * x * x) * 8;///-3 операции умножения

   cout << "X^6=" << x << endl;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота