В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
badyul
badyul
01.09.2021 05:40 •  Информатика

Написать программу, которая вычисляет произведение первых n членов ряда 1, 3, 5, 7,… Количество членов ряда задается во время работы программы (используя цикл с параметром).

Решить задачу эту задачу используя цикл с предусловием.
Решить задачу эту задачу используя цикл с постусловием.

Показать ответ
Ответ:
Светлая26
Светлая26
20.06.2021 22:56
function ptcrk(a,b,x,y,r: real): integer;
var k: integer;
begin
  k:=0;  
  if abs(sqr(x-a)+sqr(y-b)-r*r)<1.0e-9 then k:=1;
  if r*r-sqr(x-a)-sqr(y-b)>1.0e-9 then k:=2;
  ptcrk:=k;
end;
// основная программа
var a,b,x,y,r,k: real;
begin
  write('координаты центра a b: ');  readln(a,b);
  write('координаты точки x y: ');  readln(x,y);
  write('радиус: ');  readln(r);
  k:=ptcrk(a,b,x,y,r);
  if k=1 then writeln('точка на окружности');
  if k=2 then writeln('точка внутри круга');
  if k=0 then writeln('точка вне круга');
end.

координаты центра a b: 2 1
координаты точки x y: 4 1
радиус: 2.1
точка внутри круга

координаты центра a b: 2 1
координаты точки x y: 4 1
радиус: 2
точка на окружности
0,0(0 оценок)
Ответ:
sofarik3456
sofarik3456
20.03.2021 18:17
' QBASIC
CONST n = 10
DIM a(1 TO n) AS DOUBLE, b(1 TO n) AS DOUBLE, x(1 TO n) AS DOUBLE
RANDOMIZE TIMER
CLS
FOR i = 1 TO n
   a(i) = 50 * RND - 25
   b(i) = 50 * RND - 25
   IF a(i) <> 0 THEN
      x(i) = b(i) / a(i)
   ELSE
      x(i) = 0
   END IF
   PRINT USING "###."; a(i);
   PRINT " * ";
   PRINT USING "###."; x(i);
   PRINT " = ";
   PRINT USING "###."; b(i)
NEXT i

Тестовое решение:
-14.65854 *   0.53867 =  -7.89606
-14.19729 *   1.08311 = -15.37722
-17.21156 *  -0.07488 =   1.28888
 16.17024 *  -1.09750 = -17.74690
-13.80126 *  -1.06180 =  14.65417
 17.78583 *   0.83055 =  14.77207
-10.95534 *  -1.58899 =  17.40791
-11.84992 *   1.66222 = -19.69714
-24.91831 *  -0.95948 =  23.90864
-12.68757 *   0.84160 = -10.67785
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота