Написать программу которая вычисляет разность и произведение четырёх вещественных чисел, которые вводятся из клавиатуры. Нарисовать блок схему и данные ввода - вывода
// Паскаль // Программа поддерживает латиницу, кириллицу и дефисы
const // Первая буквы, англ. "a" - 65, но может быть дефис #45 first_letter = #45; // Последняя буквы, рус. "я" last_letter = #1103;
var x: string; i: integer; c: char; // Сколько раз встречает буква в слове count: array[first_letter..last_letter] of integer; begin readln(x); // Обнуляем массив for c := first_letter to last_letter do count[c] := 0; // Подсчитываем буквы в слове for i := 1 to length(x) do inc(count[x[i]]); // Выводим слово без букв, встречающихся 3 раза for i := 1 to length(x) do if count[x[i]] <> 3 then write(x[i]) end.
// Возводит действилельное число x в целую степень n Procedure Pow(Const X:real; Const n:integer; Var St:real); Var i:integer; Begin St:=1; For i:= 1 to n do St:=St*x; End;
Var x,y,St:real; n:integer; Begin y:=0; Write('x = ');ReadLn(x); Write('n = ');ReadLn(n); For n:= 1 to n do Begin Pow(x,n,St); y:=y+Cos(St); End; WriteLn('y = ',y); End.
Функцией:
// Возводит действилельное число x в целую степень n Function Pow(Const X:real; Const n:integer):real; Var i:integer; Begin result:=1; For i:= 1 to n do result:=result*x; End; Var x,y:real; n:integer; Begin y:=0; Write('x = ');ReadLn(x); Write('n = ');ReadLn(n); For n:= 1 to n do y:=y+Cos(Pow(x,n)); WriteLn('y = ',y); End.
Циклом:
Var x,y,St:real; n:integer; Begin y:=0; Write('x = ');ReadLn(x); Write('n = ');ReadLn(n); St:=1; For n:= 1 to n do Begin St:=St*x; y:=y+Cos(St); End; WriteLn('y = ',y); End.
// Программа поддерживает латиницу, кириллицу и дефисы
const
// Первая буквы, англ. "a" - 65, но может быть дефис #45
first_letter = #45;
// Последняя буквы, рус. "я"
last_letter = #1103;
var
x: string;
i: integer;
c: char;
// Сколько раз встречает буква в слове
count: array[first_letter..last_letter] of integer;
begin
readln(x);
// Обнуляем массив
for c := first_letter to last_letter do
count[c] := 0;
// Подсчитываем буквы в слове
for i := 1 to length(x) do
inc(count[x[i]]);
// Выводим слово без букв, встречающихся 3 раза
for i := 1 to length(x) do
if count[x[i]] <> 3 then
write(x[i])
end.
// Возводит действилельное число x в целую степень n
Procedure Pow(Const X:real; Const n:integer; Var St:real);
Var i:integer;
Begin
St:=1;
For i:= 1 to n do
St:=St*x;
End;
Var
x,y,St:real;
n:integer;
Begin
y:=0;
Write('x = ');ReadLn(x);
Write('n = ');ReadLn(n);
For n:= 1 to n do
Begin
Pow(x,n,St);
y:=y+Cos(St);
End;
WriteLn('y = ',y);
End.
Функцией:
// Возводит действилельное число x в целую степень n
Function Pow(Const X:real; Const n:integer):real;
Var i:integer;
Begin
result:=1;
For i:= 1 to n do
result:=result*x;
End;
Var
x,y:real;
n:integer;
Begin
y:=0;
Write('x = ');ReadLn(x);
Write('n = ');ReadLn(n);
For n:= 1 to n do
y:=y+Cos(Pow(x,n));
WriteLn('y = ',y);
End.
Циклом:
Var
x,y,St:real;
n:integer;
Begin
y:=0;
Write('x = ');ReadLn(x);
Write('n = ');ReadLn(n);
St:=1;
For n:= 1 to n do
Begin
St:=St*x;
y:=y+Cos(St);
End;
WriteLn('y = ',y);
End.