В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Alinatomil63
Alinatomil63
31.03.2021 12:45 •  Информатика

Написать программу, которая вычисляет, сколько раз введенное с клавиатуры число встречается в линейном массиве из 10 случайных чисел. pascal abc

Показать ответ
Ответ:
VikaKemer
VikaKemer
08.10.2020 21:06
Var
  a:array[1..10] of integer;
  b,i,k:integer;
begin
  Randomize;
  Write('Введите количество элементов в массиве: ');
  for i:=1 to 10 do
  begin
    a[i]:=Random(21)-10;
    Write(a[i],' ')
    end;
  Writeln;
  Write('Какое число искать? ');
  Readln(b);
  k:=0;
  for i:=1 to 10 do
    if a[i]=b then Inc(k);
  Writeln('Число встречается ',k,' раз')
end.
0,0(0 оценок)
Ответ:
AnnaIzotova53
AnnaIzotova53
08.10.2020 21:06
Var
  a:array[1..10] of integer;
  b,i,k:integer;
begin
  Randomize;
  Write('Введите количество элементов в массиве: ');
  for i:=1 to 10 do
  begin
    a[i]:=Random(21)-10;
    Write(a[i],' ')
    end;
  Writeln;
  Write('Какое число искать? ');
  Readln(b);
  k:=0;
  for i:=1 to 10 do
    if a[i]=b then Inc(k);
  Writeln('Число встречается ',k,' раз')
end.

Подробнее - на -
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота