В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
esedova61p0apim
esedova61p0apim
17.01.2023 18:52 •  Информатика

Написать программу, которая вычисляет среднее арифметическое последовательности дробных чисел, вводимых с клавиатуры. после того, как будет введено последнее число, программа должна вывести разность между минимальным и максимальным числом последовательности. количество чисел должно задаваться во время работы программы. паскаль

Показать ответ
Ответ:
Aleksiy69
Aleksiy69
19.06.2020 07:10

program raf105;

var

 n,i: integer;

 a,sum,sari,min,max: real;

begin

 write('Введите количество чисел: ');

 readln(n);

 writeln('Воодите числа по очереди');

 min:= 10000;

 max:= -10000;

 for i:=1 to n do

 begin

   readln(a);

   sum:= sum+a;

   if a > max

     then max:= a;

   if a < min

     then min:= a;

 end;

 sari:= sum/n;

 writeln('Среднее арифметическое: ',sari);

 writeln('Разность максимального и минимального числа: ',max-min);

end.

PascalABC 3.4.2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота