Написать программу, которая вычисляет значение выражения 10⋅sinx+|x4−x5|. Формат входных данных
Входной файл содержит число x. Считать, что вводимые значения x принадлежат области определения выражения.
Формат выходных данных
В выходной файл выведите ответ на поставленную задачу не менее чем с 4 знаками после десятичной точки.
Примеры:
Вход
1
Выход
8.4147
Код C#:
double x;
Console.Write("x = ");
x = Convert.ToInt32(Console.ReadLine());
x = 10 * Math.Sin(x) + Math.Abs(x*4-x*5);
Console.WriteLine("Конечный результат: x = {0:0.#####}", x);
Console.ReadKey();
Код Pascal:
Var
x:real;
Begin
Readln(x);
x := 10* Sin(x)+ abs(x*4-x*5);
write('x = ', x);
end.
Объяснение: