Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
9999Ksenya999
10.03.2023 05:29 •
Информатика
Написать программу , которая выводит целые числа в промежутке от до 50 , кратные восьми и считает их количество , сумму и произведение . мне быстрее
Показать ответ
Ответ:
SleaM4ik
10.08.2020 01:27
Var i,k,s:integer; p:longint;
begin
k:=0; s:=0; p:=1;
for i:=1 to 50 do
if i mod 8 = 0 then
begin
write(i,' ');
k:=k+1;
s:=s+i;
p:=p*i;
end;
writeln;
writeln('k = ',k,' s = ',s,' p = ',p);
end.
Результат:
8 16 24 32 40 48
k = 6 s = 168 p = 188743680
0,0
(0 оценок)
Популярные вопросы: Информатика
ksenyaandreevn
19.04.2021 05:25
Постройте таблицу истинности 1)A 2)B 3)C 4)B+C 5)B+C+A 6)(B+C+A)C...
mark02062005
26.06.2021 21:25
Определите, какое число можно заменить на точку, чтобы цикл выполнялся ровно 3 раза. 3 6 5 4...
gevochki
19.10.2020 17:50
На Python. Напишите программу для решения задачи. Написать программу нахождения суммы большего и меньшего из трех чисел....
crasavchik
06.09.2020 19:24
Выведите элементы данного списка в обратном порядке, не изменяя сам список. Входные данные Вводится список чисел. Все числа списка находятся на одной строке. Выходные...
Куропаткана666гргрг
07.05.2021 09:10
Какой из документов является алгоритмом? 1)правила техники безопасности 2)инструкция по настройке каналов телевизора 3) список класса 4)стихотворение 5)каталог библиотеки...
361212
31.12.2020 09:41
Построить формулу для определения зависимости y от x с использованием логичесикх функций и,или,если,не y=/45/ 0...
sanya1130
31.12.2020 09:41
Когда целесообразно сохранять изображения в формате bmp, в формате jpeg...
маркен2
31.12.2020 09:41
Для каждого из перечисленных ниже десятичных чисел построили двоичную запись. укажите число, двоичная запись которого содержит наибольшее количество значащих нулей....
ОМЛА
27.02.2022 19:45
Напишите программу на паскале ax^2+bx+c 0...
DarinaKim1
04.03.2023 22:46
Слово которым называют процесс создания модели? вот варианты 1) хранение 2) моделирование 3)обработка 4)представление 5) сравнение...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
k:=0; s:=0; p:=1;
for i:=1 to 50 do
if i mod 8 = 0 then
begin
write(i,' ');
k:=k+1;
s:=s+i;
p:=p*i;
end;
writeln;
writeln('k = ',k,' s = ',s,' p = ',p);
end.
Результат:
8 16 24 32 40 48
k = 6 s = 168 p = 188743680