В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
айеоник
айеоник
22.01.2022 22:19 •  Информатика

Написать программу, которая выводит на экран тоблицу Пифагора для целых чисел

Показать ответ
Ответ:
cheknutyi
cheknutyi
10.01.2022 17:00
Var
    x0, xk, dx, x: real;

function f(x: real): real;
begin
    f := exp(-x) + cos(3 * x);
end;

begin
    write('Введите промежуток и шаг ([a,b] h) ');
    readln(x0, xk, dx);
    
    x := x0;
    writeln(' x ':10, ' | ', ' f(x) ':10);
    
    repeat
        writeln(x:10:3, ' | ', f(x):10:3);
        x := x + dx;
    until x > xk;
end.

Пример вывода
Введите промежуток и шаг ([a,b] h) -1 4 0.5
        x  |      f(x)
    -1.000 |      1.728
    -0.500 |      1.719
     0.000 |      2.000
     0.500 |      0.677
     1.000 |     -0.622
     1.500 |      0.012
     2.000 |      1.096
     2.500 |      0.429
     3.000 |     -0.861
     3.500 |     -0.445
     4.000 |      0.862
0,0(0 оценок)
Ответ:
fafab232
fafab232
22.02.2020 06:52
1. N=2^{i}=2^{7}=128 символов

2. а) Поставить курсор в начало фрагмента текста, удерживая клавишу Shift, подвести указатель мыши в конец фрагмента и щелкнуть кнопкой мыши.

б) Поставить указатель мыши в начало фрагмента текста, нажать кнопку мыши и, не отпуская ее, протянуть указатель до конца фрагмента.

в) Поставить курсор в начало фрагмента текста,  удерживая клавишу Shift, нажать одну из клавиш со стрелками.

3. внешнего вида (шрифт, выравнивание, начертание и т.д.)

4. содержания (ошибки, опечатки, добавление и удаление текста и т.д.)

5. по левому краю, по центру, по правому краю, по ширине страницы

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота