В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
licicha
licicha
04.01.2022 03:30 •  Информатика

Написать программу которая выводит на экран все подмножества множества: {1,2,3,4}

Показать ответ
Ответ:
duplenkokrist9
duplenkokrist9
01.10.2020 14:27
var    
 a,b,c,d : integer;  
Begin  
   for a:=1 to 4 do    
    for b:=a+1 to 4 do        
     for c:=b+1 to 4 do    
      for d:=c+1 to 4 do        
       writeln(a:3,b:3,c:3,d:3);
     for a:=1 to 4 do
       for b:=a+1 to 4 do
        for c:=b+1 to 4 do
          writeln(a:3,b:3,c:3);
     for a:=1 to 4 do
       for b:=a+1 to 4 do
        writeln(a:3,b:3);
     for a:=1 to 4 do
       writeln(a:3);
    readln;
   End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота