В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
LeenBoom69
LeenBoom69
21.02.2020 22:26 •  Информатика

Написать программу, которая выводит таблицу значений функции у = \х - 2| + |х + 1|. диапазон изменения аргумента - от -4 до 4, шаг приращения аргумента — 0,5.

Показать ответ
Ответ:
byxanceva6kv2
byxanceva6kv2
10.09.2020 06:59
PascalABC.NET
Версия 3.3. сборка 1583 (25.11.2017)

var x:real;
begin
 x:=-4.5;
 writeln('x    y');
 for var i:=1 to 17 do
 begin
  x:=x+0.5;
  writeln(x,'    ',abs(x-2)+abs(x+1));
 end;
readln;
end.

Пример:
x  _  y
-4  _  9
-3.5  _  8
-3  _  7
-2.5  _  6
-2  _  5
-1.5  _  4
-1  _  3
-0.5  _  3
0  _  3
0.5  _  3
1  _  3
1.5  _  3
2  _  3
2.5  _  4
3  _  5
3.5  _  6
4  _  7
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота