В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
mishka1113
mishka1113
17.12.2022 04:59 •  Информатика

Написать программу, которая выводит время на электронных часах (часы:минуты:секунды).Python 0 : 18 : 44

0 : 18 : 45

0 : 18 : 46

0 : 18 : 47

Показать ответ
Ответ:
динозаврррррр
динозаврррррр
06.12.2021 22:55

Держи. На питоне

Объяснение:

n = int(input())

cool_score = 0

jumps = input().split()

sorted_jumps = sorted(jumps)

for i in range(len(jumps)):

   if i != len(jumps) - 1:

       Ni = jumps.index(sorted_jumps[i]) + 1

       Hi = sorted_jumps[i]

       if jumps.count(jumps[i]) > 1:

           jumps[i] = 'done'

       Nj = jumps.index(sorted_jumps[i + 1]) + 1

       Hj = sorted_jumps[i + 1]

       a = 'abs({} - {}) + {} - {}'.format(int(Ni), int(Nj), int(Hj), int(Hi))

       cool_score += eval(a)

print(cool_score)

0,0(0 оценок)
Ответ:
katyamarkova22
katyamarkova22
25.12.2020 19:56
Построим битовые цепочки для первого и второго уравнений. Они одинаковые:

x1 1 0 0 0 0 0 0
x2 1 1 0 0 0 0 0
x3 1 1 1 0 0 0 0
x4 1 1 1 1 0 0 0
x5 1 1 1 1 1 0 0
x6 1 1 1 1 1 1 0

y1 1 0 0 0 0 0 0
y2 1 1 0 0 0 0 0
y3 1 1 1 0 0 0 0
y4 1 1 1 1 0 0 0
y5 1 1 1 1 1 0 0
y6 1 1 1 1 1 1 0

В 3 уравнении если x1=1, то y1 обязательно должен быть равен 1. Если x1=0, значит y1 может быть равен и 1, и 0.
Получается, что первому столбцу в цепочке иксов соответствует один набор в цепочке игриков, остальным шести столбцам иксов - семь столбцов игриков. 
Получается, что количество решений равно 1 + 6*7 = 43
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота