В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Max2934
Max2934
14.01.2023 04:16 •  Информатика

Написать программу, которая:заполнит массив из 10 элементов случайными целыми числами (от 1 до 100),выведет эти числа на экран,все элементы массива, которые более чем вдвое меньше максимального заменит значением минимального элемента,выведет на экран все элементы обновлённого массива.Например, если массив будет заполнен числами:5, 10, 1, 50, 30, 15, 45, 35, 27, 31то обновлённый массив будет следующим:1, 1, 1, 50, 30, 1, 45, 35, 27, 31т.к. все значения более чем вдвое меньше максимального (50 / 2 = 25, то есть меньше 25) заменились минимальным УМОЛЯЮ!

Показать ответ
Ответ:
gabiko82
gabiko82
09.11.2021 22:47
Если матрица подаётся построчно (вводить числа без [] разделённые пробелом)

# input

matrix = []

line = list(map(int, input().split()))

matrix.append(line)

for j in range(len(line) - 1):

   line = list(map(int, input().split()))

   matrix.append(line)

print(matrix)

# k + max

k = int(input("k: "))

maximum = matrix[0][0]

counter = 0

for arr in matrix:

   for num in arr:

       if num % k == 0:

           if maximum < num:

               maximum = num

           counter += 1

print("{0} чисел, кратных {1}".format(counter, k))

if maximum != 0:

   print("Максимальное число кратное {0} - {1}".format(k, maximum))

else:

   print("Нет чисел кратных {0}".format(k))

Если одной строкой, уже массивом ([1,20,3,4],[2,5,5,5],[3,8,9,12],[8,9,10,11])

# input

matrix = input().split("],[")

matrix[0] = matrix[0][1:]

matrix[len(matrix) - 1] = matrix[len(matrix)-1][:len(matrix[len(matrix) - 1])-1]

newMatrix = []

for arr in matrix:

   line = list(map(int, arr.split(",")))

   newMatrix.append(line)

matrix = newMatrix

print(matrix)

# k + max

k = int(input("k: "))

maximum = matrix[0][0]

counter = 0

for arr in matrix:

   for num in arr:

       if num % k == 0:

           if maximum < num:

               maximum = num

           counter += 1

print("{0} чисел, кратных {1}".format(counter, k))

if maximum != 0:

   print("Максимальное число кратное {0} - {1}".format(k, maximum))

else:

   print("Нет чисел кратных {0}".format(k))


В Python с двумерных массивов, решите задачу: Для целочисленной квадратной матрицы найти число элеме
В Python с двумерных массивов, решите задачу: Для целочисленной квадратной матрицы найти число элеме
0,0(0 оценок)
Ответ:
Сасаев
Сасаев
18.10.2022 00:28

Для запуска сомандной строки:

Нажать Win+R, ввести CMD, нажать Enter.

Для получения информации о командах набрать HELP, нажать Enter

Неочевидное:

Перенаправление вывода командной строки. Значок > и >> перенаправляют вывод одной команды на вход другой. Например, так можно перенаправить вывод команды в файл:

C:\>help > cmdhelp.txt перенаправит вывод команды HELP в файл cmdhelp.txt . Если такого файла нет, он будет создан. Если есть, содержимое будет полностью заменено новыми данными. Если нужно дописать данные в существующий файл, использовать >> , например

C:\>help >> cmdhelp.txt То же самое, что и в предыдущем случае, но если файл существует, новые данные допишутся в его конец.

9. Как создать файл:

C:\>echo "test">test.txt

PS Скорее всего Windows не даст писать что либо в корень диска С:, так что для опытов лучше использовать, например, флэшку. Для изменения текущего диска в командной строке надо просто набрать букву этого диска и двоеточие. Например, флэшке виндой присвоена буква G, тогда после открытия окна командной строки надо набрать G: и нажать Enter. Приглашение ввода изменится на

G:\>

Enter вообще прикольная кнопка, жми ее почаще :)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота