В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
aptyp4ik228
aptyp4ik228
04.08.2020 18:41 •  Информатика

Написать программу, которая заполняет в MS Excel диапазон ячеек B3:B15 случайными числами от -20 до 20.

Показать ответ
Ответ:
асланбек13
асланбек13
13.09.2020 04:41

картинка

Объяснение:

Построения логических схем:

1) Определить число логических переменных (2 - А и В)

2) Определить количество базовых логических операций и их порядок (5 - НЕ А, НЕ В, НЕ А ИЛИ В, НЕ А ИЛИ НЕ В, (НЕ А ИЛИ В) И (НЕ А ИЛИ НЕ В)

3) Изобразить для каждой логической операции соответствующий ей элемент

4) Соединить вентили в порядке выполнения логических операций

Основные элементы логических схем (картинка)

НЕ (¬, черта над выражением) - значение противоположно исходному высказыванию  

И (&, ∧) - истинно, когда оба исходных высказывания истинны  

ИЛИ (∨) - ложно, когда оба исходных высказывания ложны


построить логическую схему функции, можно использовать программы
построить логическую схему функции, можно использовать программы
0,0(0 оценок)
Ответ:
лера1405
лера1405
17.08.2020 02:51

n = int(input('Введите количество элементов массива: '))

a = [int(input("Введите элемент массива: ")) for i in range(n)]

k = int(input("Введите любое число: "))

m = 0

for i in a:

   if i == k:

       m = m + 1

if m == 0:

   print ("NO")

else:

   print ("YES")

Объяснение:

Я немного подправила программу по синтаксису(были ошибки). А ещё не поняла, что нужно сделать, но вот два теста:

ТЕСТ 1:

ВВОД:

Введите количество элементов массива: 2

Введите элемент массива: 2

Введите элемент массива: 2

Введите любое число: 12

ВЫВОД ПРОГРАММЫ:

NO

ТЕСТ 2:

ВВОД:

Введите количество элементов массива: 2

Введите элемент массива: 12

Введите элемент массива: 12

Введите любое число: 12

ВЫВОД ПРОГРАММЫ:

YES

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота