В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Gjvjub000
Gjvjub000
09.12.2020 15:15 •  Информатика

Написать программу, которая запрашивает одно число с клавиатуры и выводит наименьшее круглое число, превышающее введенное. Обязательно в тетради оформить таблицу входных и выходных данных.

Показать ответ
Ответ:
русский132
русский132
21.02.2021 00:15

program Chernovik;

var a: integer;

begin

read(a);

if a mod 10 = 0 then a:=a+1;

while a mod 10 <> 0 do a:=a+1;

write(a)

end.

Объяснение:

картинка

Ввод числа

Если введено круглое число (последняя цифра числа равна 0), то увеличиваем его на 1, т.к. выведенное круглое число, должно превышать введённое

Цикл while: пока последняя цифра числа не равна 0, увеличиваем число на 1

Вывод числа


Написать программу, которая запрашивает одно число с клавиатуры и выводит наименьшее круглое число,
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота