В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
McVano
McVano
14.02.2022 06:10 •  Информатика

Написать программу, которая запрашивает у пользователя координаты точки на плоскости и определяет принадлежность точки заштрихованной области. рис прилагается.

Показать ответ
Ответ:
Alung
Alung
25.01.2021 15:48
PascalABC.NET 3.4.0, сборка 1672 от 10.06.2018
Внимание! Если программа не работает, обновите версию!

Самое глупое, что можно было придумать - использовать цикл с предусловием while ... do там, где имеется заданное число повторений:

begin
  var n:=ReadInteger('n=');
  var (s,i):=(0.0,1);
  while i<=n do begin
    s+=1/Sqr(2*i+1);
    i+=1
    end;
  Writeln('S=',s)
end.

Пример
n= 10
S=0.210988884817533

Гораздо естественнее тут выглядит цикл со счетчиком:

begin
  var n:=ReadInteger('n=');
  var s:=0.0;
  for var i:=1 to n do
    s+=1/Sqr(2*i+1);
  Writeln('S=',s)
end.

А если использовать современные возможности программирования в PascalABC.NET, решение вообще в одну строчку:

begin
  Writeln('S=',SeqGen(ReadInteger('n='),t->1/Sqr(2*t+1),1).Sum)
end.
0,0(0 оценок)
Ответ:
kucharin
kucharin
25.01.2021 15:48
PascalABC.NET 3.4.0, сборка 1672 от 10.06.2018
Внимание! Если программа не работает, обновите версию!

Самое глупое, что можно было придумать - использовать цикл с предусловием while ... do там, где имеется заданное число повторений:

begin
  var n:=ReadInteger('n=');
  var (s,i):=(0.0,1);
  while i<=n do begin
    s+=1/Sqr(2*i+1);
    i+=1
    end;
  Writeln('S=',s)
end.

Пример
n= 10
S=0.210988884817533

Гораздо естественнее тут выглядит цикл со счетчиком:

begin
  var n:=ReadInteger('n=');
  var s:=0.0;
  for var i:=1 to n do
    s+=1/Sqr(2*i+1);
  Writeln('S=',s)
end.

А если использовать современные возможности программирования в PascalABC.NET, решение вообще в одну строчку:

begin
  Writeln('S=',SeqGen(ReadInteger('n='),t->1/Sqr(2*t+1),1).Sum)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота