Написать программу на алгоритмическом языке, которая вводит пять чисел, затем выводит минимальное и максимальное из них. Программа должна сопровождаться элементами интерфейса
Если элемент стоит выше главной диагонали, то его номер столбца больше, чем номер строки. Программа будет такая: PROGRAM Matrix77 var A: array [1..7][1..7] of real; // Объявляем переменные var i, j: integer BEGIN crt; for i:= 1 to 7 do begin for j:=1 1 to 7 do read (A[i][j]); // Вводим начальный массив readln; end; for i:= 1 to 7 do begin // Проверяем, что элемент выше диагонали for j:=1 1 to 7 do if j > i then A[i][j]:=0; // Обнуляем его end; for i:= 1 to 7 do begin for j:=1 1 to 7 do write (A[i][j]); // Выводим конечный массив writeln; end; END.
Программа будет такая:
PROGRAM Matrix77
var A: array [1..7][1..7] of real; // Объявляем переменные
var i, j: integer
BEGIN
crt;
for i:= 1 to 7 do
begin
for j:=1 1 to 7 do read (A[i][j]); // Вводим начальный массив
readln;
end;
for i:= 1 to 7 do
begin // Проверяем, что элемент выше диагонали
for j:=1 1 to 7 do if j > i then A[i][j]:=0; // Обнуляем его
end;
for i:= 1 to 7 do
begin
for j:=1 1 to 7 do write (A[i][j]); // Выводим конечный массив
writeln;
end;
END.
#include <cmath>
using namespace std;
double eps = 0.000001;
double sq(double a, double b, double c)
{
double p = (a + b + c) / 2;
return sqrt(p * (p - a) * (p - b) * (p - c));
}
int main()
{
double a1, b1, c1, a2, b2, c2;
cin >> a1 >> b1 >> c1 >> a2 >> b2 >> c2;
if (sq(a1, b1, c1) >= sq(a2, b2, c2) - eps && sq(a1, b1, c1) <= sq(a2, b2, c2) + eps)
cout << "YES";
else
cout << "NO";
}