Написать программу на алгоритмическом языке (кумир) с использованием циклов с условием и использованием алгоритмов ветвления. Нужно провести робота с заданной точки в центр лабиринта. По пути робот закрашивает только те клетки, где стенка имеет разрыв (линия стены прерывается). Достигнув центра лабиринта, робот должен остановиться в закрашенной клетке.
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
int first, second, temp;
cin >> first >> second;
if (first > second)
{
temp = first;
first = abs(first * second);
second = abs(temp - second);
}
else
{
temp = second;
second = abs(second * first);
first = abs(temp - first);
}
cout << first << " " << second;
}
Объяснение:
#include <iostream> // Библиотека ввода - вывода
#include <cmath> // Библиотека с математическими функциями
using namespace std; // Пространство имен
int main()
{
int first, second, temp; // Создание целочисленных переменных:
first - первое число, вводимое с клавиатуры;second - второе число, вводимое с клавиатуры;temp - переменная, для временного хранения одного из значений.cin >> first >> second; // Вводим с клавиатуры первое и второе числа
if (first > second) // Если значение переменной first > значения переменной second
{
temp = first; // Переменная временного хранения = значению переменной first
first = abs(first * second); // Значение переменной first (большей) = модулю произведения двух чисел
second = abs(temp - second); // Значение переменной second (меньшей) = модулю разности двух чисел
}
else // Иначе
{
temp = second; // Переменная временного хранения = значению переменной second
second = abs(second * first); // Значение переменной second (большей) = модулю произведения двух чисел
first = abs(temp - first); // Значение переменной first (меньшей) = модулю разности двух чисел
}
cout << first << " " << second; // Выводим значения переменных first и second
}
return 1; // Конец программы с кодом ошибки
}
else // Иначе
{
fuel -= fuel_cons * distance_a_b; // Емкость бака = емкость бака - расход топлива на 1 км * расстояние из пункта А в пункт В (узнаем количеств оставшегося топлива)
}
int distance_b_c, weight_b; // Создание целочисленных переменных:
distance_b_c - расстояние из пункта В в пункт Сweight_b - вес груза в пункте Вcout << "Погрузка/Разгрузка в точке B: "; // Вывод сообщения в консоль
cin >> weight_b; // Ввод с клавиатуры веса груза в пункте В
weight_a += weight_b; // Выясняем, на сколько был дозагружен/разгружен самолет в пункте В (Вес в пункте А + Вес в пункте В)
fuel_cons = fuel_consumption(weight_a); // Переменной fuel_cons присваиваем возвращаемое значение из функции fuel_consumption (расход топлива на 1 км)
cout << "Расстояние от пункта B в пункт C (км): "; // Вывод сообщения в консоль
cin >> distance_b_c; // Ввод с клавиатуры расстояния из пункта В в пункт С
fuel = (distance_b_c * fuel_cons - fuel); // Выясняем, на сколько необходимо дозаправить самолет, чтобы долететь до пункта С (Емкость бака = расстояние из пункта В в пункт С * расход на 1 км - емкость бака)
cout << "В пункте B самолет необходимо дозаправить на минимум (л): "; // Вывод сообщения в консоль
cout << fuel; // Вывод значения переменной fuel
}