В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
FantomLord24
FantomLord24
18.02.2022 18:28 •  Информатика

Написать программу на C++
Дана матрицы из 3 строк и 7 столбцов. Рассматривая содержание каждого элемента столбца как длину стороны треугольника, отпечатать номера столбцов, которыми заданы равнобедренные треугольники, и число таких столбцов.

Показать ответ
Ответ:
GangsterNigga1
GangsterNigga1
15.10.2020 06:59

#include <iostream>

#include <vector>

using namespace std;

bool ok1(int a, int b, int c){

   return (a+b > c && a+c > b && b+c > a) && min(a,min(b,c)) > 0;

}

bool ok2(int a, int b, int c){

   return ok1(a,b,c) && (a == b || a == c || b == c);

}

signed main(){

   const int n = 3, m = 7;

   int arr[n][m];

   for(int i = 0; i < n; i++)

       for(int j = 0; j < m; j++)

           cin >> arr[i][j];

   vector<int> ans;

   for(int j = 0; j < m; j++)

       if(ok2(arr[0][j],arr[1][j],arr[2][j]))

           ans.push_back(j+1);

   cout << ans.size() << "\n";

   for(auto i: ans)

       cout << i << " ";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота