В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
SOFIA0209
SOFIA0209
18.11.2020 12:03 •  Информатика

Написать программу на c#! даны координаты точки а(х1,у1). определить, принадлежит ли эта точка какой-нибудь оси координат. если да, то какой.

Показать ответ
Ответ:
Ukine
Ukine
03.10.2020 06:35
Using System;

class Program
{
    static void Main()
    {
        for(var x=-2;x<=2;x++){
            for(var y=-2;y<=2;y++){
                IsPointOnAxis(x, y);
            }
        }
        Console.ReadKey();
    }

    static void IsPointOnAxis(int x, int y){
        Console.WriteLine("Point  = {0}; {1}", x, y);
        if (x*y != 0){
            Console.WriteLine("Point not on axis");
            return;
        }

        if (x == 0){
            Console.WriteLine("Point is on axis Ox");
        }else if (y == 0){
            Console.WriteLine("Point is on axis Oy");
        }
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота