В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Насятя28
Насятя28
21.12.2021 21:01 •  Информатика

Написать программу на c++ для решения следующей : вычислить z1=(xmax+ymin)/2 и z2=(xmin+ymax)/2 где xmax  и ymax  – максимальные элементы массивов x(20), y(30); xmin  и ymin  – минимальные элементы этих же массивов (вычисление максимального и минимально элементов массива осуществлять в одной подпрограмме).​

Показать ответ
Ответ:
Neronminecraft
Neronminecraft
10.10.2020 16:41

// C++17

#include <iostream>

using namespace std;

void minmax(int a[], int n, int& min, int& max)

{

   min = max = a[0];

   for(int i = 1; i < n; i++)

       if(a[i] < min)

           min = a[i];

       else if(a[i] > max)

           max = a[i];

}

void initmas(int a[], int n)

{

   for(int i=0; i < n; i++)

   {

       a[i] = rand() % 199 - 98;   // [-99,99]

       cout << a[i] << " ";

   }

   cout << endl;

}

int main()

{

   srand(time(0));

   int nx = 20, ny = 30;

   int x[nx], y[ny];

   cout << "Массив х\n";

   initmas(x, nx);

   cout << "Массив y\n";

   initmas(y, ny);

   int xmin, xmax, ymin, ymax;

   float z1, z2;

   minmax(x, nx, xmin, xmax);

   minmax(y, ny, ymin, ymax);

   z1 = (xmax + ymin) / 2.0;

   z2 = (xmin + ymax) / 2.0;

   cout << "z1 = " << z1 << ", z2 = " << z2;

   return 0;

}


Написать программу на c++ для решения следующей : вычислить z1=(xmax+ymin)/2 и z2=(xmin+ymax)/2 где
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота