В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
nastena544
nastena544
09.09.2021 04:49 •  Информатика

Написать программу на c++, которая переводит число из двоичной системы счисления в десятичную

Показать ответ
Ответ:
marina02032006
marina02032006
01.10.2020 12:27

#include <iostream>

#include <string>

#include <cmath>

using namespace std;

void main(void){

setlocale(LC_ALL, "rus");

int i,sum=0,n,r=0;

char date[255];

cout << "Введите двоичное число"<< endl;

cin >> date;

n = strlen(date);

int *arr = new int[n];


for (i = 0; i < n; i++){

 arr[i] = (int)date[i] - (int)'0';

}

for (i = 0; i < n; i++){

 cout << arr[i] << " ";

}

cout << " " << endl;

for (i = 0; i < n; i++){

 r = r + arr[i]*pow(2, n - i-1);

}

cout << "Десятичное число равно" << r;


}


Написать программу на c++, которая переводит число из двоичной системы счисления в десятичную
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота