Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
zulfiya2006
13.01.2022 21:33 •
Информатика
Написать программу на c# написать программу, удаляющую из записи числа все чётные цифры.
Показать ответ
Ответ:
drakula13055
02.10.2020 01:30
Static class Program
{
public static IEnumerable<uint> Digits(this uint X, bool Reverse = true)
{
do { yield return X % 10; } while ((X /= 10) != 0);
}
static uint ToUnsignedInt32(this IEnumerable<uint> Digits)
{
return Digits.Reverse().Aggregate((a, d) => a * 10 + d);
}
static void Main()
{
Console.WriteLine(
uint.Parse(Console.ReadLine())
.Digits()
.Where(d => d % 2 == 1)
.ToUnsignedInt32());
Console.ReadKey();
}
}
0,0
(0 оценок)
Популярные вопросы: Информатика
F1RE000
05.01.2020 11:47
2. Как компьютеры хранят информацию?...
girb13
22.05.2023 06:15
1.Таблица Клиенты (напишите поля через запятую, как минимум 6 полей). 2.Таблица Клиенты (напишите поля через запятую, как минимум 6 полей) *...
Oneganin
14.09.2022 06:06
Загадка эйнштейна )) нужно само решение в один ряд стоят 5 домов, в которых живут люди разных национальностей. француз выращивает яблони. ему 40 лет. тот, кто живет...
Obcenceee
13.05.2020 08:33
1.дана последовательность действительных чисел a1,a2,…,an. замените все ее члены, большие данного z, этим числом. подсчитать количество замен. c++...
Dima1Tap
05.02.2021 05:34
Графическая информациятекстовая информациякодовые таблицыascii, кои-8: ісимвот – 1 байтunicode: 1 cinbat-i = k xiкодирование информацииобобщение изученного в 7 классетекстграфика...
darya666666666666
11.06.2021 06:51
Оприделите значения полей документа представленного на рисунке ниже левое поле проводе поле ...
ermoloffalexan
07.10.2020 03:09
Первое государство,в котором был зажжён олимпийский огонь. а.византия б.египет в.римская империя г.эллада...
Alсу1
04.09.2020 14:20
Tea everybody knows that britain is a tea-drinking nation. tea is more than just a drink to the british – it is a way of life. many people drink it first with breakfast,...
vladaua2005p06s4b
07.10.2020 03:09
Усестры такое по оружающиму миру 3 класс : с дополнительной , интернета подготовьте сообщение об одной из народов россии и мира или о любой стране ( по своему выбору)сдетлай...
paatalizip08mh2
07.10.2020 03:09
Вставь пропущенные буквы . над подчеркнутыми словами с пропущенными окончаниями укажи число , род и падеж.найди в тексте родственные глаголы выдели в них корень выделенное...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
{
public static IEnumerable<uint> Digits(this uint X, bool Reverse = true)
{
do { yield return X % 10; } while ((X /= 10) != 0);
}
static uint ToUnsignedInt32(this IEnumerable<uint> Digits)
{
return Digits.Reverse().Aggregate((a, d) => a * 10 + d);
}
static void Main()
{
Console.WriteLine(
uint.Parse(Console.ReadLine())
.Digits()
.Where(d => d % 2 == 1)
.ToUnsignedInt32());
Console.ReadKey();
}
}