написать программу на C# Постройте таблицу значений функции y=f(x) для хÎ[a, b] с шагом h. Если в некоторой точке x функция не определена, то выведите на экран сообщение об этом.
const nn=100; var a:array[1..nn] of integer; i,n,max:integer; begin Write('n='); Read(n); randomize; max:=-100; for i:=1 to n do begin a[i]:=Random(101)-50; Write(a[i],' '); if a[i]>max then max:=a[i] end; Writeln; Writeln('Max=',max) end.
1) Вирус - это вредоносная программа, которая распространяется копируя себя (возможно не полностью). Различаются по попадания на устройство, типу заражаемых объектов распространения и типу вредоносных действий
В среднем жизненный цикл вируса такой: попадание на устройство, активация, поиск объектов для заражения, заражение, распространение
2) Вообще вирус может делать все то же, что и другая программа. Теоретически вирус может быть даже полезным. Но так или иначе он совершает действия не санкционированные самим пользователем или системой
Примеры вредоносных действий
использование ресурсов системы в своих целях (вычисления, Ддос атаки,...)удаление или порча, шифрование файловнарушение работы системы/ОСкража личных данных пользователя (напр. данных банковских карт, паролей)нарушение работы программперегрузка/блокировка линий связиспам, внедрение угрожающих/рекламных сообщений, переходы на нежелательные сайты
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
Writeln('Max=',a.Max)
end.
Пример
n= 13
-11 16 -24 5 5 3 42 45 -46 45 22 43 -4
Max=45
2. А так учат в большинстве школ...
const
nn=100;
var
a:array[1..nn] of integer;
i,n,max:integer;
begin
Write('n='); Read(n);
randomize;
max:=-100;
for i:=1 to n do begin
a[i]:=Random(101)-50;
Write(a[i],' ');
if a[i]>max then max:=a[i]
end;
Writeln;
Writeln('Max=',max)
end.
1) Вирус - это вредоносная программа, которая распространяется копируя себя (возможно не полностью). Различаются по попадания на устройство, типу заражаемых объектов распространения и типу вредоносных действий
В среднем жизненный цикл вируса такой: попадание на устройство, активация, поиск объектов для заражения, заражение, распространение
2) Вообще вирус может делать все то же, что и другая программа. Теоретически вирус может быть даже полезным. Но так или иначе он совершает действия не санкционированные самим пользователем или системой
Примеры вредоносных действий
использование ресурсов системы в своих целях (вычисления, Ддос атаки,...)удаление или порча, шифрование файловнарушение работы системы/ОСкража личных данных пользователя (напр. данных банковских карт, паролей)нарушение работы программперегрузка/блокировка линий связиспам, внедрение угрожающих/рекламных сообщений, переходы на нежелательные сайты