В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
masha91672
masha91672
15.04.2022 01:08 •  Информатика

Написать программу на c# "произвести суммирование натуральных чисел 1, 2, пока их сумма s не станет равной или превысит величину h. вывести на экран последнее слагаемое и значение суммы."

Показать ответ
Ответ:
supergirl321
supergirl321
02.09.2020 17:02

Написал на c++ т,к синтаксис шарпа не знаю, можешь переделать под себя.

#include "pch.h"

#include <iostream>

using namespace std;



int main()

{

setlocale(LC_ALL, "rus");

int summa = 0;

int h;

int i = 1;

cout << "Введите h" << endl;

cin >> h;

for(i;summa<h;)

{

 summa += i;

 i++;

}

cout <<"Сумма= "<< summa << endl <<"Последнее слагаемое = "<< i - 1 << endl;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота