Написать программу на c# работа с текстовыми файлами: имеется текстовый файл. выяснить, имеется ли в нем строка, начинающаяся с буквы «т». если да, то определить номер первой из таких строк. условие: текстовый файл для заранее создать в текстовом редакторе
using System.IO;
internal class Program
{
public const string FILE = "test.txt";
private static void Main()
{
try
{
using (var sr = File.OpenText(FILE))
{
string line;
for (var i = 0; (line = sr.ReadLine()) != null; i++)
{
if (!string.IsNullOrWhiteSpace(line) && line.Trim()[0] == 'т')
{
Console.WriteLine($"Строка {i} = {line}");
break;
}
}
}
}
catch(Exception e)
{
Console.WriteLine(e);
}
finally
{
Console.ReadLine();
}
}
}