В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Meylisa3
Meylisa3
22.06.2022 03:00 •  Информатика

написать программу на Дана матрица А (5x5). Определить массив Х из 5 элементов, каждый из
которых равен наименьшему из элементов соответствующего столбца
матрицы.

Показать ответ
Ответ:
tinapai
tinapai
27.03.2020 02:51
Чтобы квадрат вписался в круг, его диагональ должна быть равна диаметру круга. Если трактовать "уместиться" как "пролезть", то диагональ должна быть меньше диаметра..
Формулы площадей квадрата  S₁ и круга S₂ известны, что легко позволяет нам найти нужное условие.
\displaystyle S_1=a^2 \to a=\sqrt{S_1}; \ d=a \sqrt{2}= \sqrt{2S_1} \\ S_2=\frac{\pi D^2}{4} \to D=\sqrt{\frac{4S_2}{\pi}}; \\ d\ \textless \ D \to \sqrt{2S_1}\ \textless \ \sqrt{\frac{4S_2}{\pi}}; \ 2S_1\ \textless \ \frac{4S_2}{\pi} \ \to \ \boxed{\pi s_1\ \textless \ 2S_2}
Если нужно, чтобы случай, когда квадрат вписан в круг тоже учитывался, строгое неравенство следует заменить нестрогим.

// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
  var s1:=ReadReal('Площадь квадрата');
  var s2:=ReadReal('Площадь круга');
  if pi*s1<2*s2 then Writeln('Квадрат умещается в круге')
  else Writeln('Квадрат не умещается в круге')
end.

Тестовое решение:
Площадь квадрата 24.6
Площадь круга 28.4
Квадрат не умещается в круге
0,0(0 оценок)
Ответ:
Ismailll
Ismailll
15.04.2023 19:26

Складіть програму мовою С++ для знаходження функції y(x), де x Є [a, b] з кроком h. Дані для y(x), a, b, h вказані в таблиці.

y = x + sin(3x);

[a, b], h   [-1, 3], h = 0.3

Програма:

С++:

#include <iostream>

#include <cmath>

using namespace std;

int main()

{

   float y, a, b, h;

   cout << "a = ";  cin >> a;

   cout << "b = ";  cin >> b;

   cout << "h = ";  cin >> h;

   while (a <= b) {

       y = a + sin(3 * a);

       cout << "y = " << y << " при x = " << a << endl;

       a += h;

   }

}

Результат:

a = -1

b = 3

h = 0.3

-1.14112 при x = -1

-1.56321 при x = -0.7

-1.33204 при x = -0.4

-0.39552 при x = -0.1

0.764643 при x = 0.2

1.4975 при x = 0.5

1.47546 при x = 0.8

0.942254 при x = 1.1

0.528424 при x = 1.4

0.774186 при x = 1.7

1.72058 при x = 2

2.87844 при x = 2.3

3.59854 при x = 2.6

3.56297 при x = 2.9

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота