В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
АннаФайна
АннаФайна
16.07.2022 23:46 •  Информатика

написать программу на Делфи (Delphi) которая из элементов матриц А и Т, значения которых попадают в интервал (2;7) сформировать векторы Z и С соответственно.

Показать ответ
Ответ:
zaharuch
zaharuch
05.08.2020 11:13
var i,j,k,m: integer;
    s: string;
begin
  k:=0;
  for i:=1 to 1000000 do
  begin
    s:=IntToStr(i);
    m:=0;
    for j:=1 to (length(s) div 2) do
    if s[j]<>s[length(s)-j+1] then m:=1;
    if m=0 then
    begin
      inc(k); continue;
    end;  
    m:=pos('0',s);
    if m>0 then
    begin
      inc(k); continue;
    end;  
    m:=1;  
    for j:=2 to round(sqrt(i)) do 
    if i mod j = 0 then
    begin
      m:=0;
      break;  
    end;  
    if m=1 then inc(k); 
  end;
  k:=1000000-k;
  writeln('осталось чисел: ',k);
end.

осталось чисел: 544011
0,0(0 оценок)
Ответ:
MaushaLate86
MaushaLate86
05.08.2020 11:13
var i,j,k,m: integer;
    s: string;
begin
  k:=0;
  for i:=1 to 1000000 do
  begin
    s:=IntToStr(i);
    m:=0;
    for j:=1 to (length(s) div 2) do
    if s[j]<>s[length(s)-j+1] then m:=1;
    if m=0 then
    begin
      inc(k); continue;
    end;  
    m:=pos('0',s);
    if m>0 then
    begin
      inc(k); continue;
    end;  
    m:=1;  
    for j:=2 to round(sqrt(i)) do 
    if i mod j = 0 then
    begin
      m:=0;
      break;  
    end;  
    if m=1 then inc(k); 
  end;
  k:=1000000-k;
  writeln('осталось чисел: ',k);
end.

осталось чисел: 544011
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота