Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
August333
09.10.2020 13:50 •
Информатика
Написать программу на delphi: дана матрица а размерность 2xn, которая хранит координаты n точек на плоскости. определить номер точки, суммарное расстояние от которой до всех остальных наибольшее.
Показать ответ
Ответ:
alina1932
19.06.2022 02:45
//Блок-схема во вложении
//Pascal ABC.NET 3.1 сборка 1219
uses
system;
Var
d1,d2:datetime;
a:integer;
begin
writeln('1 дата:');
write('День:');readln(a);d1:=d1.AddDays(a);
write('Месяц:');readln(a);d1:=d1.AddMonths(a);
write('Год:');readln(a);d1:=d1.AddYears(a);
writeln('2 дата:');
write('День:');readln(a);d2:=d2.AddDays(a);
write('Месяц:');readln(a);d2:=d2.AddMonths(a);
write('Год:');readln(a);d2:=d2.AddYears(a);
writeln('Res:',abs((d2-d1).Days));
end.
Пример ввода:
1 дата:
День:1
Месяц:1
Год:1998
2 дата:
День:2
Месяц:1
Год:1999
Пример вывода:
Res:366
0,0
(0 оценок)
Ответ:
Небатан1542
08.03.2020 15:09
1) 64*32/8/1024 = 0,25 кб; 1 / 0,25 = 4 бит пиксель; 2^4 = 16 цветов.
2) 50*80*(ln(16)/ln(2)) = 16000 бит; 16000 / 8 = 2000 байт.
3) 64*64*(ln(256)/ln(2)) = 32768 бит / 8 / 1024 = 4 кбайт минимум.
4) 2048*1536*3 байт пиксель = 9437184 байт / 8 / 1024 = 1152 кбайт.
5) (ln(256)/ln(2)) / (ln(2)/ln(2)) =8 раз меньше стал; (текущий уменьшенный вес файла + 70 байт) * 8 =~ 560 байт если весил 1 байт.
6) (ln(64)/ln(2)) / (ln(8)/ln(2)) = 2 раза.
7) (ln(1024)/ln(2)) / (ln(32)/ln(2)) = 2 раза.
8) 32*64/8 = 256; 512 байт / 256 = 2 бит пикс; 2^2 = 4 цветов.
9) 128*128/8/1024 = 2; 4 кб / 2 = 2 бит пикс; 2^2 = 4 цветов.
10) 1024*768*16 бит пикс = 12582912 бит / 8 / 1024 / 1024 = 1,5 мбайт.
11) 1024*512/8/1024 = 64; 256 кб / 64 = 4 бит пикс; 2^4 = 16 цветов.
12) 32*128*(ln(64)/ln(2)) бит = 24576 бит / 8 / 1024 = 3 кбайта.
13) 2^24 = 16 777 216 цветов; 1240*1024*(ln(16777216)/ln(2)) бит пикс = 30474240 бит / 8 / 1024 = 3720 кбайт для одной страницы требуется.
0,0
(0 оценок)
Популярные вопросы: Информатика
kaliyeva2006amina
09.04.2022 23:43
Какие инструменты и цвета краоск в графическом редакторе paint понадобятся инфознайке, чтобы нарисовать схему метро г.москвы?...
Caxapok24
09.04.2022 23:43
Var s,k: integer; begin s: =0; for k: =7 to 11 do s: =s+11; writeln(s); end....
solnechnaya2
14.07.2020 20:46
Информационное сообщение объемом 2.5 кбайт передается со скоростью 2560 бит/мин. за сколько минут будет передано данное сообщение?...
lizamankova94
14.07.2020 20:46
Каковы причины возникновения эргономики...
kem8
19.08.2021 21:48
Інопланетянина з планети елзіка запитали : скільки тобі років? він відповів: якщо я проживу ще половину того, що прожив, то мені буде 99 років скільки років інопланетянину? з рішенням...
margaritakulak
06.12.2021 21:07
Для каких из приведенных чисел ЛОЖНО высказывание: а) НЕ (первая цифра числа чётная) И (последняя цифра числа нечётная)?1)123 2)258 3)347 4)409 5)607 6)709 7)801 б) НЕ (первая цифра...
ivancornij8
26.05.2023 13:49
Приведите по 2 примера информационных объектов...
gladiolys2003
11.04.2023 00:14
Нормализуйте мантиссу в числах: Α) 0,000156 × 10^2; Β) -0,01678 × 10^3...
solokha24
28.04.2022 16:52
У клітинку C9 ввели формулу =$C8/$A*$8. Потім цю формулу скопіювали у клітинку C11. Запишіть формулу, яка з’явилася в цій клітинці...
valia622
22.11.2022 23:29
Пусть A1, A2, A3 — произвольные события. Найти выражения для следующих событий (в виде суммы попарно несовместных слагаемых): а) среди событий A1, A2, A3 произошли все три; г) произошли...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
//Pascal ABC.NET 3.1 сборка 1219
uses
system;
Var
d1,d2:datetime;
a:integer;
begin
writeln('1 дата:');
write('День:');readln(a);d1:=d1.AddDays(a);
write('Месяц:');readln(a);d1:=d1.AddMonths(a);
write('Год:');readln(a);d1:=d1.AddYears(a);
writeln('2 дата:');
write('День:');readln(a);d2:=d2.AddDays(a);
write('Месяц:');readln(a);d2:=d2.AddMonths(a);
write('Год:');readln(a);d2:=d2.AddYears(a);
writeln('Res:',abs((d2-d1).Days));
end.
Пример ввода:
1 дата:
День:1
Месяц:1
Год:1998
2 дата:
День:2
Месяц:1
Год:1999
Пример вывода:
Res:366
2) 50*80*(ln(16)/ln(2)) = 16000 бит; 16000 / 8 = 2000 байт.
3) 64*64*(ln(256)/ln(2)) = 32768 бит / 8 / 1024 = 4 кбайт минимум.
4) 2048*1536*3 байт пиксель = 9437184 байт / 8 / 1024 = 1152 кбайт.
5) (ln(256)/ln(2)) / (ln(2)/ln(2)) =8 раз меньше стал; (текущий уменьшенный вес файла + 70 байт) * 8 =~ 560 байт если весил 1 байт.
6) (ln(64)/ln(2)) / (ln(8)/ln(2)) = 2 раза.
7) (ln(1024)/ln(2)) / (ln(32)/ln(2)) = 2 раза.
8) 32*64/8 = 256; 512 байт / 256 = 2 бит пикс; 2^2 = 4 цветов.
9) 128*128/8/1024 = 2; 4 кб / 2 = 2 бит пикс; 2^2 = 4 цветов.
10) 1024*768*16 бит пикс = 12582912 бит / 8 / 1024 / 1024 = 1,5 мбайт.
11) 1024*512/8/1024 = 64; 256 кб / 64 = 4 бит пикс; 2^4 = 16 цветов.
12) 32*128*(ln(64)/ln(2)) бит = 24576 бит / 8 / 1024 = 3 кбайта.
13) 2^24 = 16 777 216 цветов; 1240*1024*(ln(16777216)/ln(2)) бит пикс = 30474240 бит / 8 / 1024 = 3720 кбайт для одной страницы требуется.