В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
situan4
situan4
24.07.2022 16:03 •  Информатика

Написать программу: на ферме 40 животных,козы,коровы и овцы. вывести экран все возможные комбинации,при условии что коров в два раза больше чем коз. нужно,это информатика)

Показать ответ
Ответ:
sherlock0w
sherlock0w
07.10.2020 02:57
Var
  i, kor, koz, ov: integer;

begin
  for i := 1 to 40 do
  begin
    koz := i;
    kor := 2 * koz;
    ov := 40 - (koz + kor);
    if ov < 0 then break;
    writeln('Овец: ', ov, ' Коров: ', kor, ' Коз: ', koz);
  end
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота